ROSSKO API

version v2.0           http://api.rossko.ru

/GetOrders


SOAP http://api.rossko.ru/service/GetOrders

Сервис для получения изменений по заказам. Настоятельно рекомендуем получать информацию о заказах исключительно по идентификаторам.

Сервис имеет общий минутный лимит, при достижении которого перестает отвечать.

Параметры запроса

ПараметрТипОбязателенОписание
KEY1stringYesКлюч авторизации (1). Можно получить в личном кабинете или через персонального менеджера.
KEY2stringYesКлюч авторизации (2). Можно получить в личном кабинете или через персонального менеджера.
ORDER_IDSobjectСписок заказов, по которым нужно узнать статусы, элемент OrderId
idintYesНомер заказа
limitintЕсли не указывать идентификаторы заказов, но указать лимит, вернется список последних N заказов. Можно группировать с параметром type. По умолчанию 20, не может превышать 500.
typeintТип заказов, которые хотелось бы получить. Возможные варианты: 1 - неподтвержденные; 2 - неукомплектованные; 3 - несобранные; 4 - неотгруженные. Можно группировать с интервалом времени
start_datedateДата начала выборки. Дата указывается в формате Y-m-d (2017-05-31)
end_datedateДата конца выборки (включительно). Дата указывается в формате Y-m-d (2017-05-31). При указании данного параметра - параметр start_date обязателен

Пример запроса

1C
//Вх.параметры. номера заказов могут быть переданы в процедуру любом удобном виде.
МассивНомеровЗаказов = Новый Массив;
МассивНомеровЗаказов.Добавить(1234567); //Целое число - номер заказа;
МассивНомеровЗаказов.Добавить(7654321);
Попытка
СсылкаНаВебСервис = "http://api.rossko.ru/service/GetOrders?wsdl";
ОпределениеСсылки = Новый WSОпределения(СсылкаНаВебСервис);
URIПространстваИмен = ОпределениеСсылки.Сервисы[0].URIПространстваИмен;
Прокси = Новый WSПрокси(ОпределениеСсылки, URIПространстваИмен, "Orders", "OrdersSoap");
Исключение
Прокси = Неопределено;
КонецПопытки;

Если Прокси <> Неопределено Тогда
KEY1 = "you_key_1";
KEY2 = "you_key_2";

//ТипыЗначенийПараметров
ТипМассивИД = Прокси.ФабрикаXDTO.Тип(URIПространстваИмен, "ArrayOfOrderId");
ТипИД = Прокси.ФабрикаXDTO.Тип(URIПространстваИмен, "OrderId");

// В параметры Веб сервиса обязательно необходимо передавать или п.1 или п.2.
// 1. Список номеров заказов
ORDER_IDS = Прокси.ФабрикаXDTO.Создать(ТипМассивИД);
// Должен быть хотя бы один элемент массива
Для каждого ЭлементМассива Из МассивНомеровЗаказов Цикл
OrderId = Прокси.ФабрикаXDTO.Создать(ТипИД);
OrderId.Id = ЭлементМассива;
ORDER_IDS.OrderId.Добавить(OrderId);
КонецЦикла;

// 2. Возможность показать N количество заказов.
limit = 20;
type = 1;

// Ограничение выборки по датам. Необязательно. Можно комбинировать с п.2.
// Дата указывается в формате Y-m-d (2017-05-31)
start_date = Формат(НачалоГода(ТекущаяДата()),"ДФ=yyyy-MM-dd");
end_date = Формат(ТекущаяДата(),"ДФ=yyyy-MM-dd");

// Вариант п.1
Результат = Прокси.GetOrders(KEY1,KEY2,ORDER_IDS,,,,);

// Вариант п.2
Результат = Прокси.GetOrders(KEY1,KEY2,,limit,,,);

// Вариант п.2 + ограничение по датам
Результат = Прокси.GetOrders(KEY1,KEY2,,limit,,start_date,end_date);

Если Результат.success = Истина Тогда
// Есть результат поиска.
Иначе
// Ничего не найдено
КонецЕсли;
КонецЕсли;

Ответ

200:

Стандартный ответ
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="http://api.rossko.ru/">
  <SOAP-ENV:Body>
    <ns1:GetOrdersResponse>
      <ns1:OrdersResult>
        <ns1:success>true</ns1:success>
        <ns1:OrdersList>
          <ns1:Order>
            <ns1:id>1234567</ns1:id>
            <ns1:created_date>01.02.2017 16:15:22</ns1:created_date>
            <ns1:delivery_date>06.02.2017</ns1:delivery_date>
            <ns1:total_price>363.13</ns1:total_price>
            <ns1:payment_status>Не оплачен</ns1:payment_status>
            <ns1:detail>
              <ns1:delivery_type>Курьерская доставка</ns1:delivery_type>
              <ns1:delivery_address>Новосибирск, Мира, 14</ns1:delivery_address>
              <ns1:payment_type>Оплата банковским платежом</ns1:payment_type>
              <ns1:company_name>ООО "Рога и Копыта"</ns1:company_name>
              <ns1:company_requisites>ИНН 0123456789</ns1:company_requisites>
              <ns1:comment>Звонить после 18:00</ns1:comment>
            </ns1:detail>
            <ns1:parts>
              <ns1:part>
                <ns1:guid>NSII0009734515</ns1:guid>
                <ns1:partnumber>IQ16TT#4</ns1:partnumber>
                <ns1:name>Свеча зажигания</ns1:name>
                <ns1:brand>Denso</ns1:brand>
                <ns1:price>363.13</ns1:price>
                <ns1:count>1</ns1:count>
                <ns1:delivery>5</ns1:delivery>
                <ns1:status>
                  <ns1:confirmed>-</ns1:confirmed>
                  <ns1:supplied>-</ns1:supplied>
                  <ns1:collected>-</ns1:collected>
                  <ns1:shipped>-</ns1:shipped>
                </ns1:status>
              </ns1:part>
            </ns1:parts>
          </ns1:Order>
        </ns1:OrdersList>
      </ns1:OrdersResult>
    </ns1:GetOrdersResponse>
  </SOAP-ENV:Body>
</SOAP-ENV:Envelope>

Параметры ответа

ПараметрТипОбязателенОписание
successbooleanYesРезультат запроса
messagestringСообщение описывающее ошибку
OrdersListobjectСписок заказов о которых имеется информация, элемент Order
idintYesИдентификатор заказа
created_datestringYesДата совершения заказа
delivery_datestringЖелаемая дата доставки
total_pricefloatYesСумма заказа
payment_statusstringYesСтатус оплаты
detailobjectYesПодробное описание выбранной доставки и оплаты, а так же другая информация
delivery_typestringYesИнформация о типе доставки
delivery_addressstringАдрес доставки
payment_typestringYesИнформация о типе оплаты
company_namestringНаименование организации
company_requisitesstringРеквизиты организации
commentstringКомментарий к заказу
partsobjectYesПодробное описание номенклатуры заказа, part
guidstringYesКод номенклатуры
partnumberstringYesАртикул номенклатуры
namestringYesНаименование номенклатуры
brandstringYesНаименование производителя
pricefloatYesСтоимость
countintYesОстаток
deliveryintYesДни доставки
statusobjectYesСтатусы номенклатуры
confirmedstringYesПодтверждено
suppliedstringYesКомплектуется
collectedstringYesСобрано
shippedstringYesОтгружено