ROSSKO API

version           http://api.rossko.ru

/GetOrders


SOAP http://api.rossko.ru/service/v2.0/GetOrders

Сервис для получения изменений по заказам. Настоятельно рекомендуем получать информацию о заказах исключительно по идентификаторам.
Получить информацию можно:
- по id заказа
- по списку id
- за период start_date - end_date
- последние N заказов
- заказы с определенным статусом

Параметры запроса

ПараметрТипОбязателенОписание
KEY1 string Да Ключ авторизации (1).
Можно получить в личном кабинете или через персонального менеджера. Пример: cba94510b02ecccef994b52711c84413
KEY2 string Да Ключ авторизации (2).
Можно получить в личном кабинете или через персонального менеджера. Пример: 8c7b4ba7acc716fe5bd7a80c513ad930
ORDER_IDS array Содержит в себе элемент OrderId
OrderId array Содержит в себе элемент id
id integer Номер заказа
limit int Если не указывать идентификаторы заказов, но указать лимит, вернется список последних N заказов. Можно группировать с параметром type. По умолчанию 20, не может превышать 500.
type int Тип заказов, которые хотелось бы получить. Можно группировать с интервалом времени
Возможные варианты:
   1 - неподтвержденные
   2 - неукомплектованные
   3 - несобранные
   4 - неотгруженные
start_date date Дата начала выборки. Дата указывается в формате Y-m-d (2017-05-31)
end_date date Дата конца выборки (включительно). Дата указывается в формате Y-m-d (2017-05-31). При указании данного параметра - параметр start_date обязателен

Пример запроса

PHP1C
$connect = array(
'wsdl' => 'http://api.rossko.ru/service/GetOrders',
'options' => array(
'connection_timeout' => 1,
'trace' => true
)
);

$param = array(
'KEY1' => 'you_key_1',
'KEY2' => 'you_key_2',
'ORDER_IDS' => array(
array(
'id' => 1234567
),
array(
'id' => 1234568
)
)
);

$query = new SoapClient($connect['wsdl'], $connect['options']);
$result = $query->GetOrders($param);

print_r($result);
//Вх.параметры. номера заказов могут быть переданы в процедуру любом удобном виде.
МассивНомеровЗаказов = Новый Массив;
МассивНомеровЗаказов.Добавить(1234567); //Целое число - номер заказа;
МассивНомеровЗаказов.Добавить(7654321);
Попытка
СсылкаНаВебСервис = "http://api.rossko.ru/service/GetOrders?wsdl";
ОпределениеСсылки = Новый WSОпределения(СсылкаНаВебСервис);
URIПространстваИмен = ОпределениеСсылки.Сервисы[0].URIПространстваИмен;
Прокси = Новый WSПрокси(ОпределениеСсылки, URIПространстваИмен, "Orders", "OrdersSoap");
Исключение
Прокси = Неопределено;
КонецПопытки;

Если Прокси <> Неопределено Тогда
KEY1 = "you_key_1";
KEY2 = "you_key_2";

//ТипыЗначенийПараметров
ТипМассивИД = Прокси.ФабрикаXDTO.Тип(URIПространстваИмен, "ArrayOfOrderId");
ТипИД = Прокси.ФабрикаXDTO.Тип(URIПространстваИмен, "OrderId");

// В параметры Веб сервиса обязательно необходимо передавать или п.1 или п.2.
// 1. Список номеров заказов
ORDER_IDS = Прокси.ФабрикаXDTO.Создать(ТипМассивИД);
// Должен быть хотя бы один элемент массива
Для каждого ЭлементМассива Из МассивНомеровЗаказов Цикл
OrderId = Прокси.ФабрикаXDTO.Создать(ТипИД);
OrderId.Id = ЭлементМассива;
ORDER_IDS.OrderId.Добавить(OrderId);
КонецЦикла;

// 2. Возможность показать N количество заказов.
limit = 20;
type = 1;

// Ограничение выборки по датам. Необязательно. Можно комбинировать с п.2.
// Дата указывается в формате Y-m-d (2017-05-31)
start_date = Формат(НачалоГода(ТекущаяДата()),"ДФ=yyyy-MM-dd");
end_date = Формат(ТекущаяДата(),"ДФ=yyyy-MM-dd");

// Вариант п.1
Результат = Прокси.GetOrders(KEY1,KEY2,ORDER_IDS,,,,);

// Вариант п.2
Результат = Прокси.GetOrders(KEY1,KEY2,,limit,,,);

// Вариант п.2 + ограничение по датам
Результат = Прокси.GetOrders(KEY1,KEY2,,limit,,start_date,end_date);

Если Результат.success = Истина Тогда
// Есть результат поиска.
Иначе
// Ничего не найдено
КонецЕсли;
КонецЕсли;

Ответ

200:

Стандартный ответ
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="http://api.rossko.ru/">
  <SOAP-ENV:Body>
    <ns1:GetOrdersResponse>
      <ns1:OrdersResult>
        <ns1:success>true</ns1:success>
        <ns1:OrdersList>
          <ns1:Order>
            <ns1:id>1234567</ns1:id>
            <ns1:created_date>01.02.2017 16:15:22</ns1:created_date>
            <ns1:delivery_date>06.02.2017</ns1:delivery_date>
            <ns1:total_price>363.13</ns1:total_price>
            <ns1:payment_status>Не оплачен</ns1:payment_status>
            <ns1:detail>
              <ns1:delivery_type>Курьерская доставка</ns1:delivery_type>
              <ns1:delivery_address>Новосибирск, Мира, 14</ns1:delivery_address>
              <ns1:payment_type>Оплата банковским платежом</ns1:payment_type>
              <ns1:company_name>ООО "Рога и Копыта"</ns1:company_name>
              <ns1:company_requisites>ИНН 0123456789</ns1:company_requisites>
              <ns1:comment>Звонить после 18:00</ns1:comment>
            </ns1:detail>
            <ns1:parts>
              <ns1:part>
                <ns1:guid>NSII0009734515</ns1:guid>
                <ns1:partnumber>IQ16TT#4</ns1:partnumber>
                <ns1:name>Свеча зажигания</ns1:name>
                <ns1:brand>Denso</ns1:brand>
                <ns1:price>363.13</ns1:price>
                <ns1:count>1</ns1:count>
                <ns1:delivery>5</ns1:delivery>
                <ns1:comment>Комментарий к строке заказа</ns1:comment>
                <ns1:status>
                  <ns1:confirmed>-</ns1:confirmed>
                  <ns1:supplied>-</ns1:supplied>
                  <ns1:collected>-</ns1:collected>
                  <ns1:shipped>-</ns1:shipped>
                </ns1:status>
              </ns1:part>
            </ns1:parts>
          </ns1:Order>
        </ns1:OrdersList>
      </ns1:OrdersResult>
    </ns1:GetOrdersResponse>
  </SOAP-ENV:Body>
</SOAP-ENV:Envelope>

Параметры ответа

ПараметрТипОбязателенОписание
success boolean Да Результат запроса
message string Сообщение описывающее ошибку
OrdersList array Содержит в себе элемент Order
Order array Содержит в себе информацию о заказе
id integer Да Идентификатор заказа
created_date string Да Дата совершения заказа
delivery_date string Желаемая дата доставки
total_price string Да Сумма заказа
payment_status string Да Статус оплаты
detail array Подробное описание выбранной доставки и оплаты, а так же другая информация
delivery_type string Да Информация о типе доставки
delivery_address string Адрес доставки
payment_type string Да Информация о типе оплаты
company_name string Наименование организации
company_requisites string Реквизиты организации
comment string Комментарий к заказу
parts array Да Содержит в себе элемент part
part array Содержит в себе информацию о строке заказа
guid string Да Код номенклатуры
partnumber string Да Артикул номенклатуры
name string Да Наименование номенклатуры
brand string Да Наименование производителя
price string Да Стоимость
count integer Да Количество
delivery integer Да Дни доставки
comment string Комментарий оставленный к строке заказа
status array Статусы номенклатуры
confirmed string Да Подтверждено
supplied string Да Комплектуется
collected string Да Собрано
shipped string Да Отгружено