ROSSKO API

version v2.0           http://api.rossko.ru

/GetCheckout


SOAP http://api.rossko.ru/service/GetCheckout

Сервис для оформления заказа.

Параметры запроса

ПараметрТипОбязателенОписание
KEY1stringYesКлюч авторизации (1). Можно получить в личном кабинете или через персонального менеджера.
KEY2stringYesКлюч авторизации (2). Можно получить в личном кабинете или через персонального менеджера.
deliveryobjectYesЭлемент списка доставки
delivery_idstringYesИдентификатор доставки. Можно посмотреть в сервисе GetCheckoutDetails
citystringГород. Поле является обязательным, если тип доставки не равен самовывозу.
streetstringУлица. Поле является обязательным, если тип доставки не равен самовывозу.
housestringДом
officestringКвартира\офис
paymentobjectYesЭлемент списка оплаты
payment_idintYesИдентификатор оплаты. Можно посмотреть в сервисе GetCheckoutDetails
company_namestringНаименование организации. Поле является обязательным, если тип оплаты - банковский платеж.
company_requisitestringРеквизиты организации. Поле является обязательным, если тип оплаты - банковский платеж.
contactobjectYesЭлемент списка контактов
namestringYesФИО покупателя
phonestringYesКонтактный номер
commentstringКомментарий для оператора
delivery_partsbooleanYesДоставлять заказ по частям
PARTSobjectYesСписок заказываемой номенклатуры, элемент Part
partnumberstringYesАртикул номенклатуры. Можно посмотреть в сервисе GetSearch
brandstringYesНаименование производителя. Можно посмотреть в сервисе GetSearch
stockstringYesНеобходимый склад. Можно посмотреть в сервисе GetSearch
countstringYesНеобходимое количество
commentstringКомментарий к позиции в заказе. Ограничение 50 символов.

Пример запроса

1C
Попытка
СсылкаНаВебСервис = "http://api.rossko.ru/service/GetCheckout?wsdl";
ОпределениеСсылки = Новый WSОпределения(СсылкаНаВебСервис);
URIПространстваИмен = ОпределениеСсылки.Сервисы[0].URIПространстваИмен;
Прокси = Новый WSПрокси(ОпределениеСсылки, URIПространстваИмен, "Checkout", "CheckoutSoap");
Исключение
Прокси = Неопределено;
КонецПопытки;

Если Прокси <> Неопределено Тогда
KEY1 = "you_key_1";
KEY2 = "you_key_2";

// Типы значений параметров
ArrayOfDelivery = Прокси.ФабрикаXDTO.Тип(URIПространстваИмен, "ArrayOfDelivery");
ArrayOfPayment = Прокси.ФабрикаXDTO.Тип(URIПространстваИмен, "ArrayOfPayment");
ArrayOfContact = Прокси.ФабрикаXDTO.Тип(URIПространстваИмен, "ArrayOfContact");
ArrayOfParts = Прокси.ФабрикаXDTO.Тип(URIПространстваИмен, "ArrayOfParts");
Part = Прокси.ФабрикаXDTO.Тип(URIПространстваИмен, "Part");

// Входные параметры
delivery = Прокси.ФабрикаXDTO.Создать(ArrayOfDelivery);
delivery.delivery_id= "000000001"; // Идентификатор доставки. Можно посмотреть в сервисе GetCheckoutDetails
delivery.city = "Новосибирск"; // Поле является обязательным, если тип доставки не равен самовывозу.
delivery.street = "Бетонная"; // Поле является обязательным, если тип доставки не равен самовывозу.
delivery.house = "14";
delivery.office = "222";

payment = Прокси.ФабрикаXDTO.Создать(ArrayOfPayment);
payment.payment_id = 1; // Идентификатор оплаты. Можно посмотреть в сервисе GetCheckoutDetails
payment.company_name = "ООО Р и К"; // Наименование организации. Поле является обязательным, если тип оплаты - банковский платеж.
payment.company_requisite = "ИНН 0123456789"; // Реквизиты организации. Поле является обязательным, если тип оплаты - банковский платеж.

contact = Прокси.ФабрикаXDTO.Создать(ArrayOfContact);
contact.name = "Иванов И.И.";
contact.phone = "+7-222-333-2233";
contact.comment = "Любой ваш комментарий";

delivery_parts = Истина;

// Это код для заполнения табличной части по товару. При количестве номенклатуры больше 1 - ставить внутрь цикла по ТЧ. Например как в закоментированом коде.
PARTS = Прокси.ФабрикаXDTO.Создать(ArrayOfParts); // Список заказываемой номенклатуры (PARTS)
//Для каждого СтрокаТабличнойЧасти Из Заказ.Товары Цикл
СтрокаТЧ = Прокси.ФабрикаXDTO.Создать(Part);
СтрокаТЧ.partnumber = "333114"; // Артикул номенклатуры. Можно посмотреть в сервисе GetSearch
СтрокаТЧ.brand = "KYB"; // Наименование производителя. Можно посмотреть в сервисе GetSearch
СтрокаТЧ.stock = "HST154"; // Необходимый склад. Можно посмотреть в сервисе GetSearch
СтрокаТЧ.count = 2;
PARTS.Part.Добавить(СтрокаТЧ);
//КонецЦикла;
// Окончание заполнения строки ТЧ

Результат = Прокси.GetCheckout(KEY1,KEY2,delivery,payment,contact,delivery_parts,PARTS);

Если Результат.success = Истина Тогда
// Заказ оформлен. Обрабатываем ответ
Иначе
// Не оформлено. Смотрим причины в Результат.message
КонецЕсли;
КонецЕсли;

Ответ

200:

Стандартный ответ
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="http://api.rossko.ru/">
  <SOAP-ENV:Body>
    <ns1:GetCheckoutResponse>
      <ns1:CheckoutResult>
        <ns1:success>true</ns1:success>
        <ns1:OrderIDS>
          <ns1:id>1234567</ns1:id>
        </ns1:OrderIDS>
        <ns1:ItemsList>
          <ns1:Item>
            <ns1:partnumber>IQ16TT#4</ns1:partnumber>
            <ns1:brand>Denso</ns1:brand>
            <ns1:count>1</ns1:count>
            <ns1:price>363.13</ns1:price>
            <ns1:total_price>363.13</ns1:total_price>
            <ns1:delivery>5</ns1:delivery>
          </ns1:Item>
        </ns1:ItemsList>
        <ns1:ItemsErrorList>
          <ns1:ItemError>
            <ns1:partnumber>IQ16TT#4</ns1:partnumber>
            <ns1:brand>Denso</ns1:brand>
            <ns1:count>1</ns1:count>
            <ns1:stock>HST123</ns1:stock>
            <ns1:message>Нет в наличии</ns1:message>
          </ns1:ItemError>
        </ns1:ItemsErrorList>
      </ns1:CheckoutResult>
    </ns1:GetCheckoutResponse>
  </SOAP-ENV:Body>
</SOAP-ENV:Envelope>

Параметры ответа

ПараметрТипОбязателенОписание
successbooleanYesРезультат запроса
messagestringСообщение описывающее ошибку
OrderIDSobjectСписок идентификаторов сформированных заказов. Заказы с авиадоставкой разбирваются на нексколько
idintYesИдентификатор заказа
ItemsListobjectYesСписок заказанной номенклатуры, элемент Item
partnumberstringYesАртикул номенклатуры
brandstringYesНаименование производителя
countintYesЗаказанное количество
pricefloatYesСтоимость
total_pricefloatYesОбщая стоимость
deliveryintYesДни доставки
ItemsErrorListobjectYesСписок заказанной номенклатуры которую не удалось заказать, элемент ItemError
partnumberstringYesАртикул номенклатуры
brandstringYesНаименование производителя
countintYesЗаказанное количество
stockstringYesСклад
messagestringYesСообщение описывающее ошибку